Hướng dẫn cài đặt wifi marketing cho Mikrotik với WifiBiz

Các bước cài đặt wifi marketing trên Mikrotik

Áp dụng cho RouterOS v6.32 trở đi, các bản cũ hơn thì thư mục hotspot sẽ thay đổi.
Để cài đặt thành công, các bạn cần theo các bước sau:
  1. 1.
    Tạo id của thiết bị (NAS_ID) trên trang admin.wifibiz.net
  2. 2.
    Cài đặt router Mikrotik sao cho nó hoạt động bình thường như một router kết nối internet. (Lưu ý phải có internet)
  3. 3.
    Chạy đoạn script cài đặt.
  4. 4.
    Gán port hoặc interface vào bridge mới tạo ra bởi script.

Chi tiết các bước.

Bước 1 và Bước 2
Các bạn thực hiện bình thường, không có gì khó khăn.
Lưu ý rằng đoạn code sau sẽ sử dụng dải IP 10.5.50.0/24 vì thế nếu router bạn đang dùng dải IP này thì hãy đổi sang dải IP khác để đoạn code sau chạy tốt.
Bước 3: Chạy đoạn script cài đặt.
  • Copy đoạn code sau về notepad của window hoặc bất kỳ trình soạn thảo text nào mà bạn có:
1
#
2
# Best Wifi-Marketing provider: http://smartwifi.com.vn
3
#
4
{
5
:local redirectUrl "https://wifibiz.net/wifi/NAS_ID"
6
/interface bridge
7
add name=bridge-wifibiz
8
/ip hotspot profile
9
add hotspot-address=10.5.50.1 html-directory=/flash/wifibiz login-by=\
10
http-chap,http-pap name=wifibiz radius-accounting=no use-radius=yes
11
/ip hotspot user profile
12
set [ find default=yes ] shared-users=1000
13
/ip pool
14
add name=wifibiz-pool ranges=10.5.50.2-10.5.50.254
15
/ip dhcp-server
16
add address-pool=wifibiz-pool disabled=no interface=bridge-wifibiz lease-time=\
17
1h name=dhcp-wifibiz
18
/ip hotspot
19
add address-pool=wifibiz-pool disabled=no interface=bridge-wifibiz name=\
20
$redirectUrl profile=wifibiz
21
/ip address
22
add address=10.5.50.1/24 comment="hotspot network" interface=bridge-wifibiz \
23
network=10.5.50.0
24
/ip dhcp-server network
25
add address=10.5.50.0/24 comment="hotspot network" gateway=10.5.50.1
26
/ip dns
27
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
28
/ip firewall nat
29
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
30
src-address=10.5.50.0/24
31
/ip hotspot walled-garden
32
add dst-host=wifibiz.net
33
add dst-host=api.wifibiz.net
34
add dst-host=static.wifibiz.net
35
add dst-host=analytics.smartwifi.vn
36
add dst-host=*.wifibiz.net
37
add dst-host=*smartwifi*
38
add dst-host=use.fontawesome.com dst-port=443
39
add dst-host=maxcdn.bootstrapcdn.com dst-port=443
40
add dst-host=fonts.googleapis.com dst-port=443
41
/radius
42
add address=178.128.51.224 secret=Zi0HgArisaKoevwz service=hotspot timeout=15s
43
/tool fetch url="https://raw.githubusercontent.com/smartwifivn/mikrotik-hotspot/master/login.html" \
44
mode=https dst-path=/flash/wifibiz/login.html
45
/tool fetch url="https://raw.githubusercontent.com/smartwifivn/mikrotik-hotspot/master/alogin.html" \
46
mode=https dst-path=/flash/wifibiz/alogin.html
47
}
Copied!
  • Thay thế đoạn "NAS_ID" bằng NAS_ID mà bạn tạo ra trong admin.wifibiz.net
  • Chọn toàn bộ đoạn code vừa sửa và bấm copy (Ctrl-C trong windows)
  • Mở winbox, kết nối với Mikrotik, bấm menu New Terminal để mở ra cửa sổ console.
  • Bấm chuột phải vào cửa sổ Terminal và chọn Paste
  • Bấm enter để hoàn thành chạy đoạn code.
Bước 4: Hoàn thành
Sau khi xong bước 3, lúc này trong Mikrotik đã tạo ra một bridge có tên bridge-wifibiz, nhiệm vụ lúc này là gán port hoặc wlan cần triển khai wifi marketing vào bridge này để sử dụng:
  1. 1.
    Từ giao diện winbox, bấm chọn menu Bridge
  2. 2.
    Ở tab Bridge bạn có thể kiểm tra sự tồn tại của bridge-wifibiz
  3. 3.
    Chuyển sang tab Ports
  4. 4.
    Tại tab Ports bạn có thể thấy các danh sách các port đã được gán (ví dụ gán vào bridge mặc định). Bấm đúp chuột vào một port cần sử dụng và chuyển mục Bridge sang bridge-wifibiz, port đó sẽ là dịch vụ wifi marketing, lúc này chỉ việc gán Access Point vào port đó và phát sóng wifi marketing của bạn.
  5. 5.
    Tại tab Ports, nếu interface/port bạn muốn dùng chưa xuất hiện thì bấm nút + để thêm mới.
Tới đây thì wifi marketing đã có thể hoạt động, nếu chưa trơn chu, bạn có thể reboot lại router để thử.
Một số trường hợp trang đăng nhập không hiển thị (mà hiển thị trang đăng nhập mặc định của Mikrotik) thì bạn có thể sửa bằng cách tải file sau, giải nén và upload 2 file login.html và alogin.html vào thư mục hotspot của dịch vụ vừa tạo.
Nếu bạn gặp khó khăn vui lòng liên hệ đội ngũ support bằng cách tạo ticket từ trang web này hoặc liên hệ với thông tin đăng trên trang web: https://smartwifi.com.vn
Last modified 1yr ago